Project

General

Profile

Issue #2122

SIM working on Replicant 6.0 0004 RC1, SIM not found on Replicant 6.0 0004 RC2

Added by Denis 'GNUtoo' Carikli about 2 months ago. Updated 8 days ago.

Status:
Resolved
Priority:
Normal
Category:
Telephony and mobile data
Target version:
Start date:
09/06/2020
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed
Device:
Unknown
Grant:
#1

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Category set to Telephony and mobile data
I've got several reports on IRC on this issue:
  • On one report the SIM card was found in Replicant 6.0 0004 RC1 but not on Replicant 6.0 0004 RC2
  • On another report the SIM card was found in Replicant 6.0 0003 but not on Replicant 6.0 0004 RC2
I've tried myself on Replicant 6.0 0004 RC2 and so far here what I found:
  • In logcat -b radio we can see that the modem boots fine and we get Samsung IPC messages after that
  • The SIM isn't recognized
  • All the modem information in Settings->About phone->Status->SIM status are "Not available"
  • The IMEI information in information in Settings->About phone->Status->IMEI information looks perfectly fine.
#2

Updated by Denis 'GNUtoo' Carikli about 2 months ago

I'll bisect as it will be way faster than other methods.

#4

Updated by Denis 'GNUtoo' Carikli 8 days ago

  • Status changed from New to Resolved
  • Assignee set to Denis 'GNUtoo' Carikli
  • Resolution set to fixed

The fix has been merged already, and tested too.

Also available in: Atom PDF