Project

General

Profile

Issue #2152

Test the RC3 on the supported devices

Added by Denis 'GNUtoo' Carikli 8 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
10/25/2020
Due date:
% Done:

100%

Estimated time:
Resolution:
fixed
Device:
Unknown
Grant:
Type of work:
User testing
#1

Updated by Denis 'GNUtoo' Carikli 8 months ago

Current status:

Image Device Boots1 IMEI2
i9100 Galaxy S II (GT-I9100) OK OK
i9300 Galaxy S III (GT-I9300) OK OK
i9305 Galaxy S III 4G (GT-I9305) OK N/A
n7000 Galaxy Note (GT-N7000) OK OK
n7100 Galaxy Note II (GT-N7100) OK OK
maguro Galaxy Nexus (GT-I9250) OK OK
espresso3g Galaxy Tab 2 7.0 GSM (GT-P3100) OK OK
espressowifi Galaxy Tab 2 7.0 Wi-Fi (GT-P3110) OK N/A
n5100 Galaxy Note 8.0 (GT-N5100) OK OK
n5110 Galaxy Note 8.0 (GT-N5110) OK N/A

Feel free to add your tests in a new reply and then add them to the summary here.

This way we can still understand who to contact for more details if a given test fails.

1 Tests if the image boots until the laucher or not.

2 Tests if it's possible to retrieve the IMEI in the settings. If not the modem is probably not working.

#2

Updated by Emmett Brown 8 months ago

I tried to flash a galaxy S3 4G i9305.
It boots correctly.

I didn't try to insert a simcard. I assume it's not going to work :)

#3

Updated by Denis 'GNUtoo' Carikli 8 months ago

Thanks for the report, I've added it in the table above.

Denis.

#4

Updated by Denis 'GNUtoo' Carikli 8 months ago

The telephony seems to work on the GT-I9300 (I was able to call my voicemail).

During my boot tests, I also upgraded from 0003 to 0004 RC3 on many devices, but only one of them had extra applications installed, and probably all of them were all upgraded from the same Replicant version.

Normally users would be expected to wipe their data to install this release, because the keys generated during the build are different from Wolfgang's generated keys. These keys are used to sign the Applications that are built as part of the release, like the phone application, the launcher, etc.

So to make it easier to install this release, especially because we fixed a very serious privacy issue, I tried to find a way around that, but it's very experimental:
  • It's based on a CyanogenMod/LineageOS patch that didn't go in CyanogenMod/LineageOS, and was modified a lot on top of that.
  • It has been developed for this release, and not extensively tested at all yet.
  • LineageOS doesn't even officially support that kind of upgrades, it has instead some unofficial way to do it that may or may not work. It's also a bit similar to Replicant's way to do it.
  • I don't have deep enough knowledge on that part yet: if something goes wrong, the data partition still needs to be wiped to make Replicant boot, and I don't know yet how to recover from that.

As people expect it to work, we need to validate if upgrades from the 6.0 0003, 6.0 0004 RC1, 6.0 0004 RC2 work fine, with a wide variety of applications installed, however we don't have any tutorial yet for backuping up and restoring the data partition.

And until this is widely tested, we really need to be able to restore the data partition to safely test the upgrade on existing installations.

I'll try to write a tutorial for that in order to help people to be able to test more diverse configurations, and report here when I've something that could be used for that.

#5

Updated by Denis 'GNUtoo' Carikli 7 months ago

  • Blocked by Issue #2161: Finish [[RestoreApplicationInternalData]] added
#6

Updated by Denis 'GNUtoo' Carikli 7 months ago

  • Blocked by Issue #2162: Finish [[BackupTheDataPartition]] added
#7

Updated by Denis 'GNUtoo' Carikli 7 months ago

  • % Done changed from 0 to 20
#9

Updated by Denis 'GNUtoo' Carikli 5 months ago

  • Assignee set to Denis 'GNUtoo' Carikli
  • Resolution set to fixed

I add this one as fixed as the tests are now done and the RC4 has been published.

If we need more tests for the RC3 for some reason, we can still add them here but it'd be best to keep the bug as "fixed" as otherwise it'll shows as something to fix before releasing the 0004.

#10

Updated by _I3^ RELATIVISM 3 months ago

  • Type of work User testing added
#11

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Status changed from New to In Progress
#12

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • % Done changed from 20 to 100
#13

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • % Done changed from 100 to 0
#14

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Status changed from In Progress to New
#15

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • % Done changed from 0 to 100

For some reason I can't manage to close this bug completely as "Closed" doesn't appear in "Status"

#16

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Blocked by deleted (Issue #2162: Finish [[BackupTheDataPartition]])
#17

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Blocked by deleted (Issue #2161: Finish [[RestoreApplicationInternalData]])
#18

Updated by Denis 'GNUtoo' Carikli about 2 months ago

  • Status changed from New to Closed

The related issues were blocking the closing of the bug.

Also available in: Atom PDF