Project

General

Profile

Actions

Issue #2179

closed

Find easy ways to make an UART cable for the Galaxy Tab 2 (and similar devices)

Added by Denis 'GNUtoo' Carikli over 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
Website and wiki content
Target version:
-
Start date:
11/24/2020
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:
Unknown
Grant:
Type of work:
Unknown
Actions #1

Updated by Denis 'GNUtoo' Carikli over 1 year ago

  • Subject changed from Document how to make UART cables for the Galaxy Tab 2 to Find easy ways to make an UART cable for the Galaxy Tab 2 (and similar devices)

The issue is that making a cable is way too complicated:

< Viciouss> GNUtoo: I had a total of 4 cables as I bought the n8020 and n8010 to complete my collection and a bit later I was able to get a spare n8000 with a malfunctioning but still usable charger chip somewhere late in 2018, they were all relatively cheap at that point [...]
< Viciouss> As you have to switch the pins around for the uart connector and my solderings skills are... great... I wasted the first connector, but I learned from that and glued the second one after soldering :D
< Viciouss> The biggest problem while soldering are pins 20 and 21 as they are right next to each other
< Viciouss> For TXD and RXD
[...]
< Viciouss> And there is a small sheet of metal that connects the pin and the circuit in the connector, when you disassemble you should make sure that it sticks to the pin so that there is something to attach to, if you manage to rip it off, it will make things considerably more difficult

From the above discussion (from #replicant on Freenode) we can learn that it requires very advanced soldering skills and probably advanced soldering iron and equipement to make, which is bad news.

And breakout boards are most probably hard to find:

<@GNUtoo> Viciouss: I vaguely remember that back in the time, Sparkfun was seling custom breakout connectors for the HTC Dream strange USB connector
[...]
< Viciouss> there is a 30 pin breakout board for the tab/note but it's retired in all the shops I found :|
[...]
< Viciouss> I wonder whether a standard 30pin fpc breakout board would work

We could also try to find images of various adapter for that connector. I at least have an USB host adapter and an SD card adapter (visible through lsusb).

They may or may not be easier to solder on.

Actions #2

Updated by _I3^ RELATIVISM over 1 year ago

  • Type of work Unknown added
Actions #3

Updated by Denis 'GNUtoo' Carikli about 1 month ago

  • Status changed from New to Resolved
  • Assignee set to Denis 'GNUtoo' Carikli

I've documented how to do it here https://redmine.replicant.us/projects/replicant/wiki/GalaxyTabSerial and I've now managed to make 2 cables out of that to get the UART.

The issue is that it doesn't print the kernel logs and I don't know how to get it to do that.

Denis.

Actions

Also available in: Atom PDF