Project

General

Profile

Actions

Issue #2287

closed

mat2: upstream the ability to keep zip compression level

Added by Denis 'GNUtoo' Carikli about 2 months ago. Updated 14 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
12/06/2021
Due date:
% Done:

100%

Estimated time:
Upstream patch status:
Patches accepted
Grant:
Type of work:
Build system integration, Communication (mails, contacting people, etc), Python programming, User testing
Actions #1

Updated by Denis 'GNUtoo' Carikli about 2 months ago

I didn't find a way to run a script that creates bootanimation zip files from an svg file in Android.mk

Because of that I resorted to making the bootanimation zip reproducible and easily verifiable and I included the reproducible zip files directly instead.

To do that fast, I used mat2, but mat2 changes the compression level of the zip files and Android doesn't accept compressed zip files for the bootanimation zip.

So I've asked mat21 if they would accept a patch to keep the compression level.

Assuming that the zip compression is the same for all files, the implementation looks relatively easy to do (it's probably easier than making the zip operation reproducible without mat2).

1 bug #160

Actions #2

Updated by Denis 'GNUtoo' Carikli 14 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Upstream patch status changed from Work not started to Patches accepted
Actions

Also available in: Atom PDF