Project

General

Profile

Issue #615

button presses may be received as two presses

Added by Andrew Engelbrecht over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Telephony and mobile data
Target version:
Start date:
08/09/2013
Due date:
% Done:

0%

Estimated time:
Resolution:
wontfix
Device:
Grant:
Type of work:

Description

i was activating a debit card with charles schwab, and was getting errors when entering the long number.

eventually, i was transfered to a service rep. who monitored a repeat attempt, and said that the numbers were appearing twice, which is something they have never seen before, despite monitoring 3-4 activations per day.

when listening to the automated voice, i heard it breaking up a bit, despite my signal having full bars on a 3G connection, while plugged into power, and with usb tethering active.

instead of holding the number pad buttons for a medium or a long period of time, the solution was to press each button as quickly as possible. sometimes, the button wouldn't light up or make a tone, despite getting a quick yet significant tap. i would attempt those buttons again, sometimes multiple times. using this method, i was able to get it to work.

again, the rep. said they haven't seen this kind of behaviour before. they said the numbers were delayed, too. so it could be an issue on their end, but it seems like a combo of their system meeting a phone with unexpected behaviour.

#1

Updated by Paul Kocialkowski over 8 years ago

I had a hard time figuring out what you are talking about. Can you confirm your issue is about DTMF tones, that are used to send numbers during calls?

#2

Updated by Andrew Engelbrecht over 8 years ago

yeah, it seemed like a problem with DTMF tones. if the number '1' was being held for too long, then the receiving end apparently interpreted it as '1' being pressed twice.

#3

Updated by Paul Kocialkowski about 8 years ago

I am not sure this is a problem of Replicant. Can you tell whether it has the same behavior with CyanogenMod? As far as I know, DTMF implementation is very simply and should be flawless, but I could revisit the code if CyanogenMod doesn't behave the same. It could be an issue from the other party. Did you experience this with any other service that uses DTMF?

#4

Updated by Andrew Engelbrecht about 8 years ago

i haven't tried it with any other numbers. also, i'm not using replicant right now. :-(

the people there said they'd never seen that happen before. i haven't called them back on cyanogenmod yet, as i don't have a reason to right now. also, they may have fixed the problem by now, so i couldn't be certain cyanogenmod works unless i tried with replicant again.

#5

Updated by Paul Kocialkowski about 8 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Let's close the issue for now, may someone reopen it later if it happened again.

#6

Updated by Flo Debian over 6 years ago

I'd like to reopen this issue.

I'm using a Galaxy S2, 4.2 0003 with bug #1137 fix.

When I am using DTMF, about 80% of the keys pressed fire twice. This has been an issue for long but at the beginning it wasn't that bad. I was experiencing:

.) Dialing into conference calls means to enter a pin. This pin is repeated after I enter it. So I know that most of the digits were sent twice.
.) Using another provider for calling abroad. I dial a local number and then the original phone number I want to be connected with.
.) Listening to my voicemail box I pressed a number which deletes the message. All over sudden the next message was deleted, too.

When I am using these services I have to use my old Nokia now.

Some other issues I realized:
.) I was using an Galaxy S before where I experienced that as well but most of the times it worked after some tries.
.) I was in a rual area for some days. I only had an 'G' on my reception indicator. And DTMF worked. After coming back I tried only to use 2G networks but no change, I couldn't use my phone for the services mentioned above.
.) It doesn't make a difference if I press the keys quickly or slowly or if I let it the phone do (writing the number then some 2sec-pauses and the the pin and then having the phone dialing everything on its own)

I hope a solution can be found because I need these services pretty frequently.

Thanks.

#7

Updated by Paul Kocialkowski over 6 years ago

  • Status changed from Closed to Feedback
  • Target version changed from Replicant 4.0 to Replicant 4.2
  • Resolution deleted (worksforme)

Please submit radio logs of the current behaviour and logs of a working transaction in e.g. CyanogenMod.

I have implemented DTMF "as it should be done" and I see nothing wrong with it (it works well for me), so you'll have to point out exactly what is wrong if you wish to get this fixed.

#8

Updated by Andrew Engelbrecht over 6 years ago

That's fine with me.

Strangely I ran into the same problem with my i9300 running cyanogenmod. The solution/workaround was to disable dial pad touch tones in the phone settings. now when i enter numbers on a telephone line key presses make no sound, but the information gets through.

#9

Updated by Flo Debian over 6 years ago

I disabled the dial pad touch tones as well and it seems to work. I'd be happy with this workaround. I will test it for something like two weeks and report my experiences here (or earlier if the problem comes back). Thank you for this hint.

Even if this solution works for me I am willing to provide log etc if it's in general interest for this project.

#10

Updated by Denis 'GNUtoo' Carikli almost 6 years ago

  • Category set to Framework
#11

Updated by Paul Kocialkowski almost 6 years ago

  • Category changed from Framework to Telephony and mobile data
  • Status changed from Feedback to Closed
  • Resolution set to wontfix

I don't think this is specific to Replicant, so I'll close the issue, especially now that there is a working workaround.

Also available in: Atom PDF