Project

General

Profile

Actions

Issue #63

closed

Missing akmd.free script in system.img.

Added by Sam Noble almost 11 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Framework
Target version:
Start date:
02/13/2012
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed
Device:
Nexus One
Grant:
Type of work:

Description

In at least the 2.3 0002 passion images, there is no /system/bin/akmd.free script.

Thus there is no screen rotation on the Nexus One.

(screen rotation seems to work fine on 2.2 0008 passion image. Where akmd.free exists.)

Actions #1

Updated by Sam Noble almost 11 years ago

/system/bin/akmd exists and is a small script which calls akmd.free just as in the working 2.2 0008 image.

Actions #2

Updated by Sam Noble almost 11 years ago

Today I briefly ran 2.3 0002 again, and pushed the akmd.free from 2.2 0008
It seemed to work OK, though I only ran the phone on Gingerbread for 10 or 15 minutes, and did experience one spontaneous reboot in that time.

Actions #3

Updated by Paul Kocialkowski almost 11 years ago

The spontaneous reboot was perhaps because of modem crash caused by our faulty RIL.

Good to know it's only because of the missing script. I'll include it in the next release.

Actions #4

Updated by Paul Kocialkowski over 10 years ago

  • Status changed from New to Resolved
  • Resolution set to fixed

Should be fixed in 2.3 0003 images, please confirm.

Actions #5

Updated by Paul Kocialkowski over 10 years ago

Was fixed once again in git as apparently it wasn't fixed in 0003. Please someone confirm as soon as next images are out.

Actions #6

Updated by Denis 'GNUtoo' Carikli about 10 years ago

  • Assignee changed from Denis 'GNUtoo' Carikli to Paul Kocialkowski

The Replicant nexus one went from GNUtoo to paulk.

Denis.

Actions #7

Updated by Paul Kocialkowski about 10 years ago

  • Status changed from Resolved to Closed

I confirm that the issue has been fixed in the 0004 images.

Actions #8

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 39 to Framework
  • Device Nexus One added
Actions

Also available in: Atom PDF