Project

General

Profile

Feature #675

OpenGL ES support

Added by Jesper Pedersen almost 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
Start date:
10/17/2013
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:
Grant:
Type of work:

Description

It seems that a lot of applications rely on the OpenGL ES APIs including free software applications.
The application Document Viewer [1][2] needs the OpenGL ES 1.1 API to function properly.

[1] http://redmine.replicant.us/boards/9/topics/855
[2] the bug report for the application: https://github.com/dschuermann/document-viewer/issues/11

#1

Updated by Jesper Pedersen almost 8 years ago

Doing a little research I found that Mesa [1][2] implements both OpenGL ES 1.1 and 2.0 [3]. Mesa is MIT licensed so we should be able to use it.

I'm currently trying to find out if it can be ported to Replicant 4.0, but I'm a bit out of my league here since I've never ported something like this before.

[1] https://en.wikipedia.org/wiki/Mesa_%28software%29
[2] http://mesa3d.org/intro.html
[3] http://mesa3d.org/opengles.html

#2

Updated by Paul Kocialkowski almost 8 years ago

Yes, I know about mesa and I'm already working on using it instead of the (incomplete) Google EGL implementation. That is for Replicant 4.2 though, if it turns out to be doable (it is still currently way too slow for being usable on old devices like the Nexus S).

#3

Updated by Paul Kocialkowski almost 8 years ago

It turns out that mesa is way too slow to be used on the devices (both with swrast/softpipe and swrast/llvmpipe). We'll still be using the incomplete Android EGL implementation. Any work to improve that is welcome.

#4

Updated by Paul Kocialkowski almost 8 years ago

  • Status changed from New to Rejected
  • Resolution set to duplicate

Duplicate of #705

Also available in: Atom PDF