Project

General

Profile

Issue #681

Zxing doesn't work on Samsung S3

Added by Simon Josefsson almost 8 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Normal
Category:
Framework
Target version:
Start date:
11/02/2013
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

Camera works, but zxing doesn't manage to scan QR codes. On IRC it was suggested this was because another color space is used, and the problem is related to missing 3d acceleration (?).

Tested replicant-4.0 0005.

#1

Updated by Paul Kocialkowski almost 8 years ago

  • Status changed from New to Rejected
  • Resolution set to duplicate

This is not really a specific issue but rather the lack of proper EGL implementations that makes us use RGB565 preview format while zxing only accepts yuv. We already had the discussion at some point and it turned out that the Android compatibility document mentions that the camera module must be able to output YUV, which ours cannot do.

#2

Updated by Simon Josefsson almost 8 years ago

Which component would have to be reverse engineered and re-implemented in order to fix this? Since it works on stock ROM and CyanogenMod, I assume there is no fundamental technical reason it can't work in Replicant.

Btw, is there a policy to close feature request issues in the bug tracker? Or which bug is this a duplicate of? I couldn't find any open issue about EGL when I looked.

Btw Thanks for all your work!

#3

Updated by Paul Kocialkowski almost 8 years ago

This is about the missing graphics acceleration, but we could have a better software-only EGL implementation, so it makes sense to open a bug about it. On the other hand, we inherit that inability from AOSP, so it's not a Replicant issue per-se.

There is no policy, I do pretty much what I want around here (and sometimes have to act according what GNUtoo says). Anyway your issue is closed because it's not a problem with the Zxing application per-se, but a problem with EGL. You could open ten million bug reports about every app that requires features our EGL implementation doesn't deliver, and that would make no sense. So I prefer to close them because it's one single issue. I'm still thinking about whether it's worth opening an issue for the missing EGL features. The bug tracker is mostly about bugs, not really missing features that are known to be missing (else you can open a bug saying that the phone's GPS doesn't work with Replicant, etc), but that's not a bug, that's just missing features and we all know about them.

#4

Updated by Paul Kocialkowski almost 8 years ago

Duplicate of #705

#5

Updated by Denis 'GNUtoo' Carikli almost 6 years ago

  • Category changed from 117 to Framework
  • Device Galaxy S 3 (I9300) added

Also available in: Atom PDF