Project

General

Profile

Actions

Issue #825

closed

No PIN code invite after a boot with a new SIM card

Added by Anonymous almost 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Telephony and mobile data
Target version:
Start date:
02/17/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:
Galaxy S (I9000)
Grant:
Type of work:

Description

I installed replicant 4.2 on a cm 10.1.3 and there wasn't any PIN code invite after flash / wipe data.

I then flashed cm 10.2.1, wipe datan connected successfully to the network, boot to recovery, flashed replicant 4.2 then PIN code invite popped up and I successfully connected to the network.

Then, I switch of the smartphone, swipe the SIM card with another one, boot the system and no PIN code invite.

At this point, nothing can get the PIN code invite back, wipe data, flashing a new mode etc

The "baseband version" in the settings display is set to "unknown" when there is no PIN code invite.

Anyway, I'd like to know the modem version you develop on the i9000 maybe it is related, I dit get connection to the network with JV3 and JVK for instance, I tried others modems too.

Please try the scenario with 2 different cards, if it doesn't do the same for you I'll submit some logs I don't have for the moment.

Actions #1

Updated by Anonymous almost 9 years ago

Is there a way, a command or something, to force the PIN code invit when it doesn't appear after booting ? Switching plane mode on then off doesn't work.

Actions #2

Updated by Anonymous almost 9 years ago

A precision, the system "sets himself" to english rather than the local language when the PIN code invite not displaying bug occurs.

Little correction in the bug description, the M on modem in "At this point, nothing can get the PIN code invite back, wipe data, flashing a new modeM etc"

Actions #3

Updated by Paul Kocialkowski almost 9 years ago

Seems like a duplicate of #711. main and radio logs could confirm (see GettingLogs).
This is most likely not a PIN-code related issue, but the RIL crashing.

Actions #4

Updated by Paul Kocialkowski almost 9 years ago

  • Status changed from New to In Progress
Actions #5

Updated by Paul Kocialkowski almost 9 years ago

You can try the binary provided in #711 and see if it fixes it, in addition to providing radio and main logs.

Actions #6

Updated by Paul Kocialkowski almost 9 years ago

  • Status changed from In Progress to Closed
  • Resolution set to duplicate
Actions #7

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 69 to Telephony and mobile data
  • Device Galaxy S (I9000) added
Actions

Also available in: Atom PDF