Project

General

Profile

Issue #867

No mobile network / no SIM detected with fresh install of 4.2 on I9000M

Added by Benjamin Rochefort over 7 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Category:
Telephony and mobile data
Target version:
Start date:
03/02/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:
Galaxy S (I9000)
Grant:
Type of work:

Description

Please find attached two log files (main and radio) - adb logcat command was launched while phone was booting. Phone is Samsung Galaxy S I9000M (not I9000).


Files

main.log (61.9 KB) main.log Benjamin Rochefort, 03/02/2014 12:17 AM
radio.log (67.1 KB) radio.log Benjamin Rochefort, 03/02/2014 12:17 AM
radio2.log (58.6 KB) radio2.log Benjamin Rochefort, 03/04/2014 07:43 PM
BatteryHungMain.log.gz (18 KB) BatteryHungMain.log.gz Xan VFR, 03/05/2014 04:47 PM
BatteryHungRadio.log.gz (14.8 KB) BatteryHungRadio.log.gz Xan VFR, 03/05/2014 04:47 PM

Related issues

Related to Replicant - Issue #1783: SIM card not recognized (regression, was working with Replicant 4.2)FeedbackWolfgang Wiedmeyer04/05/2017

Actions
#1

Updated by Xan VFR over 7 years ago

I had the same problem one week ago (I forgot to report it) when I used a spare battery. Even when I put the original battery back I couldn't connect to the mobile network. I got an error problem I can't remember.

I installed CM 10.1.3 and I got an error message like "wrong/invalid IMEI number detected", but the phone got connection to the network. After that, installed Replicant 4.2 and got reception back.

#2

Updated by Benjamin Rochefort over 7 years ago

Some additional information:
- everything works fine with CM 10.1.3
- I downloaded the fixed libsamsung-ril.so of bug #711 - didn't help

#3

Updated by Benjamin Rochefort over 7 years ago

Benjamin Rochefort wrote:

Some additional information:
- everything works fine with CM 10.1.3
- I downloaded the fixed libsamsung-ril.so of bug #711 - didn't help

And here are the radio traces when booting with the new libsamsung-ril.so from bug #711.

Hope this helps!

#4

Updated by Xan VFR over 7 years ago

Problem happened again.

My phone hung: it had the button lights on and couldn't get the screen on, so I had to remove the battery. Powered on and I had no connection to mobile network (empty triangle in notification area).

See atatached logs.

I tried turning off/on, rebooting and turning on/off wifi (with proprietary firmwares) and no success connecting to mobile network.

Looking at the mobile network configuration I see no APNs and I get error trying to connect to mobile networks.

I noticed that Plane mode got activated on error or unexpected reboot (it happened, for instance, when I was doing an oandbackup and when it was backuping up contacts phone rebooted). Turned Plane mode off and no success.

Rebooted into Recovery mode and wiped Dalvik cache (I don't know what for) and on start updating Android and optimizing apps message was shown. No mobile connection.

Rebooted into Recovery mode and reinstalled Replicant 4.2 zip file without wiping data/factory reset and got no mobile connection.

Rebooted into Recovery mode and reinstalled Replicant 4.2 zip file wiping data/factory reset and phone hung on first screen. Rebooted (repeatedly pressing back button) and got no mobile connection.

Rebooted into Recovery mode and flashed cm-10.1.3-galaxysmtd.zip without wiping data/factory reset and got mobile connection. This time, although, I got a repeated error with CyanogenMod account app so I had to reboot phone over and over (it didn't happen the first time).

Rebooted into Recovery mode and reinstalled Replicant 4.2 zip file wiping data/factory reset and got mobile connection back.

I've restored my contacts and I'm reinstalling apps.

#5

Updated by Paul Kocialkowski over 7 years ago

Benjamin Rochefort: Thanks for the report. This seems to be purely an error in our software, which is reporting SIM ready state while it's not, hence triggering SIM I/O requests which apparently make the modem hang.

Xan VFR: It is likely that you are not experiencing the same issue. Your problem is a duplicate of #711 and you should try the solution provided there. The bad news is that you probably lost your IMEI along the way. Sorry.

#6

Updated by Xan VFR over 7 years ago

Thank you very much, Paul.

I'll try the fix when I have time and I'll ask the phone company about getting another SIM with a correct IMEI.

#7

Updated by Xan VFR over 7 years ago

Problem solved! Thank you very much again, Paul.

I thought this bug was fixed in Replicant 4.2 0001

#8

Updated by Paul Kocialkowski over 7 years ago

The IMEI is not something stored on the SIM card: it's instead phone-specific and is written numerically in the file that apparently got corrupted. That's independent from the mobile telephony network operator.

#9

Updated by Denis 'GNUtoo' Carikli over 5 years ago

  • Device Galaxy S (I9000) added
#10

Updated by Denis 'GNUtoo' Carikli over 5 years ago

  • Category changed from 69 to Telephony and mobile data
#11

Updated by Denis 'GNUtoo' Carikli almost 3 years ago

  • Category changed from Telephony and mobile data to SIM card not recognized
#12

Updated by Denis 'GNUtoo' Carikli almost 3 years ago

  • Category changed from SIM card not recognized to Telephony and mobile data
  • Status changed from New to Resolved

Also available in: Atom PDF