Project

General

Profile

Issue #921

Add sound scenarios for the GTA04 A3

Added by Denis 'GNUtoo' Carikli over 7 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
Framework
Target version:
-
Start date:
06/03/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed
Device:
GTA04
Grant:
Type of work:

Description

The GTA04 A3 have different alsa controls than the >= A4.

#1

Updated by Denis 'GNUtoo' Carikli over 7 years ago

Maybe it is the cause of the following issue:
When I plug the headset the button is recognized, the sounds profiles are switched somehow:
Removing the headset makes the music stop.
But the music is always only played trough the internal speakers instead of the headset.

Denis

#2

Updated by Paul Kocialkowski over 7 years ago

  • Status changed from New to Resolved
  • Resolution set to fixed

The ALSA controls between A3 and A4 are the same (as far as playback goes, else there is the hardware modem routing that is a difference). The problem was a mistake in generic device configuration includes that caused the emulator (goldfish) audio policy configuration to be included in place of the GTA04 one. This was fixed with: https://gitorious.org/replicant/device_goldelico_gta04/commit/6198c76b91db0e07e55b8ff27de40d41c72937c5

Also, the button was not behaving properly since the keylayout file was not copied to the image. This was fixed with: https://gitorious.org/replicant/device_goldelico_gta04/commit/65a071191c46ac1f55c0e070db7bdc149be8b1cc

Thanks for reporting this!

#3

Updated by Denis 'GNUtoo' Carikli almost 6 years ago

  • Category changed from 75 to Framework
  • Device GTA04 added

Also available in: Atom PDF