Project

General

Profile

Issue #939

Phonecall terminates without busy signal

Added by Jan Prunk almost 6 years ago. Updated over 2 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
Telephony and mobile data
Target version:
Start date:
06/16/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:

Description

Hi Paul,

I occasionally experience the bug on the S3 during calling.
Sometimes, when I start the call and my phone rings for about some random seconds 5-20 sec. the call gets silently terminated.
It doesn't provide a busy signal or anything it just hangs up the call. I assume that it happens when the other side cancels my phonecall
during when their side is ringing. I have the 4.0.4 replicant build.

Kind regards,
yang

History

#1

Updated by Paul Kocialkowski almost 6 years ago

How exactly is this an issue? The phone call is supposed to get terminated when the other end hangs up and it doesn't go to voicemail, right?

Do you have any reference of another behavior that should happen, for instance from CyanogenMod? If so, I'll look into it.

#2

Updated by Jan Prunk almost 6 years ago

Hi Paul !

It is an issue because I don't get the correct signal. For example:

I am calling someone and the call is silently being terminated, it just does "click" and hangs up without any kind of voice signal (like beep-beep-beep busy tone). Keep in mind that I don't reach the caller to hear their voice, the call is ringing on the other side for random time (maybe 1-7 times), then it gets dismissed on my side with the "click" tone and no signal. Later I get called from those parties who are either telling me "Hey you called me 3 times and I was busy" or they'd say "Hey you called 3 times and I replied and there was no answer from you", because after the phone does "click" I don't know either the other party "received the call and answered it" or either they do a busy-signal or something else, so it is kind of annoying because I keep on dialing after that happens... Sometimes I keep dialing 3 or 4 times, until the phone-connection is actually established so that I can really talk with the other party and sometimes when I dial their side doesn't ring at all and the phone instantly does "click" and hangs up. If they are actually giving the busy-signal and don't want to pick up the phone and it does just "click" on my side, then I would keep on dialing them presuming that I couldn't reach them and it is probably annoying, because they have to cancel the call each time which keeps them disturbing.

I don't use CyanogenMod so don't know how that behaves.

Kind regards,
Jan

#3

Updated by Paul Kocialkowski over 5 years ago

  • Target version deleted (Replicant 4.0)

Please try this with the Replicant 4.2 0003 images and let me know if it's still a problem.

#4

Updated by Jan Prunk about 5 years ago

Hi Paul,

I can confirm that with 4.2 0003 there is a similar issue, but this time when I call the other person, the phone just does "click" and hangs up after maybe two/three seconds, so it's impossible to tell if the called person is in a conversation (because there is no busy tone signal) or if the phone cannot sync with the base station or something (I don't know about that), because I place the call and it just clicks and ends the call. This time it doesn't even ring for a few seconds anymore. IT DOESN'T APPEAR VERY OFTEN, but when it does I just keep repeating calls and maybe on the other side, my call just gets canceled. It would be "good" if there would always be a busy tone signal before the actual dropout of the call.

Kind regards,
yang

#5

Updated by Denis 'GNUtoo' Carikli over 4 years ago

  • Category changed from 117 to Telephony and mobile data
  • Device Galaxy S 3 (I9300) added
#6

Updated by Wolfgang Wiedmeyer about 3 years ago

  • Target version set to Replicant 4.2
#7

Updated by Wolfgang Wiedmeyer almost 3 years ago

I suppose that this issue is still there with Replicant 6.0?

#8

Updated by Wolfgang Wiedmeyer almost 3 years ago

  • Status changed from New to Feedback
#9

Updated by Jan Prunk over 2 years ago

This problem still appears in Replicant 6.0 0002. When I am trying to dial to a number that is being in another busy call, it gives me a single "click" termination response, without the busy tone signal.

#10

Updated by Wolfgang Wiedmeyer over 2 years ago

  • Assignee deleted (Paul Kocialkowski)
  • Target version changed from Replicant 4.2 to Replicant 6.0
  • Device added
  • Device deleted (Galaxy S 3 (I9300))

Also available in: Atom PDF