Project

General

Profile

Issue #975

SIM card functionality is broken when the device is encrypted.

Added by Richard "Cylus" Palmer about 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Telephony and mobile data
Target version:
Start date:
09/19/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:
Galaxy S 3 (I9300)

Description

I have no idea what would cause this, but when my GT-I9300 is encrypted, it fails to acknowledge and use the SIM card most of the time. Getting the device to use the SIM card often requires rebooting several times or leaving the device powered off for several minutes. As soon as I reformatted the encrypted partition, SIM functionality returned to normal, and upon re-encrypting it, SIM functionality broke again.

This issue is compounded by the fact that once you encrypt the device, ClockworkMod doesn't know how to reformat/wipe the encrypted partition: <http://redmine.replicant.us/issues/969>

History

#1

Updated by Paul Kocialkowski almost 5 years ago

  • Status changed from New to Rejected
  • Resolution set to duplicate

Duplicate of #849 -- The problem was fixed in the code and will be part of the next batch of Replicant 4.2 images. You can build a Samsung-RIL binary and push it to your device or ask me for one to push on IRC.

#2

Updated by Richard "Cylus" Palmer almost 5 years ago

Sweet. I was worried that this was a complex issue to diagnose (as it doesn't happen every time the device boots), and that it would take a while to fix. The likelihood of someone snatching my device is low, and the only sensitive file is my already-encrypted KeePassX database file, so I'll just wait for the next release.

Thank you so much for the fix, and for maintaining Replicant in general!

#3

Updated by Denis 'GNUtoo' Carikli almost 4 years ago

  • Category changed from 117 to Telephony and mobile data
  • Device set to Galaxy S 3 (I9300)

Also available in: Atom PDF