Project

General

Profile

Issue #993

SIM card isn't fully usable when SIM lock is engaged

Added by Richard "Cylus" Palmer almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
10/14/2014
Due date:
% Done:

100%

Resolution:
Device:

Description

When the SIM card is locked, the device is only partially able to access it, even after entering the SIM PIN. Specifically, SIM lock cannot be disabled, SIM PIN cannot be changed, and the voicemail number on the SIM card cannot be read.

The updated Samsung RIL might have already fixed this, so I apologize for reporting this if it is no longer an issue.

History

#1 Updated by Paul Kocialkowski almost 3 years ago

Please try with the latest version of Samsung-RIL (as you suggested) and get back to me with logs if the issue is still there.

#2 Updated by Richard "Cylus" Palmer almost 3 years ago

Sorry it took so long to respond.

How do I go about updating the Samsung-RIL? I see the source code is available at <https://gitorious.org/replicant/hardware_ril_samsung-ril/source/73cde24d9690e2b9d4fb588fa8cc54fa50ef0b3e:&gt;, but it doesn't come with compile/installation instructions, and Web searches were unsuccessful at finding the instructions elsewhere.

#3 Updated by Paul Kocialkowski almost 3 years ago

You have to grab the full replicant source code and run:

make libsamsung-ril

There will be new images released soon, too.

#4 Updated by Richard "Cylus" Palmer almost 3 years ago

I've been downloading the source code for almost four days, and it still hasn't finished. I'll continue downloading, but if there is any way to compile this component without downloading the source code to all the unrelated components, it would really speed this up.

#5 Updated by Paul Kocialkowski almost 3 years ago

New images with the Samsung-RIL rewrite were released in the meantime. You can simply install those. There is no way around building Samsung-RIL without the rest of Replicant's code, though.

#6 Updated by Richard "Cylus" Palmer almost 3 years ago

That's unfortunate about the source requirement, but I suppose it can't be helped. I'll get the new release installed after work and test the SIM card functionality. I'm looking forward to having the device be encryptable too!

#7 Updated by Richard "Cylus" Palmer almost 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

There seems to be a couple small issues with the SIM card still, but one issue is likely caused by the SIM card being buggy (the device says "no service" at all times, regardless of actual connection status; my old SIM card didn't have this issue) and the other is likely due to some blob being needed (the "additional settings" option in the menu of the "phone" application doesn't work). There is no longer any difference in functionality between times when the SIM card is locked and when it is unlocked.

Thank you for all your time and effort in maintaining Replicant!

#8 Updated by Paul Kocialkowski almost 3 years ago

Please open a new reports about these two issues. I can reproduce the additional settings one. The other one seems specific to your device, so please provide logs of the radio buffer: GettingLogs.

#9 Updated by Richard "Cylus" Palmer almost 3 years ago

Phone menu bug: <https://redmine.replicant.us/issues/1125>

I'm not even sure it's specific to my device, as my device only does it with one SIM card. Other SIM cards work just fine. Not only that, but the company behind the odd SIM card has a multitude of other issues in their other interfaces as well (the Web interface and the voicemail system are both very wonky). It's highly probably that the SIM card is just defective.

I'll open the issue on that anyway, I could be completely misjudging. I have no idea what I'm doing, so it would be easy for me to jump to incorrect conclusions. SIM bug: <https://redmine.replicant.us/issues/1131>

#10 Updated by Paul Kocialkowski almost 3 years ago

Thanks, I'll follow up on each specific issue!

Also available in: Atom PDF